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Single Click Scoring bug in Noxturnal 7.2.1

Bug description

Users running Noxturnal version 7.2.1 in one of the following languages will receive an unhandled exception error when clicking the Single Click Scoring button. The affected languages are:

  • CH – Chinese
  • CZ - Czech
  • DK - Danish
  • NL - Dutch
  • EE - Estonian
  • FI - Finnish
  • IT - Italian
  • JP - Japanese
  • LH - Lithuanian
  • PL – Polish
  • PT – Portuguese
  • ES – Spanish
  • SE – Swedish


 

Root Cause

The cause of this issue is the default single click group setting for the Bruxim-Phasic event type is set to Bruxism;Submental but “Bruxism” is not the key for the Bruxism signal group, it is CheekEMG (name).

This works in English, German, and French because the fallback method uses the label and finds a match.  But, when working in a translated language, the label is translated and the fallback method doesn’t find a match. Thus resulting in a list containing a null value, causing the exception.


 

Workaround

Users who have this issue can follow these steps to work around this issue:

  1. Open noxturnal in admin mode in the language of interest
    1. This can also be done per user without going into Admin mode
  2. Go to settings
  3. Go to event types
  4. Select bruxism-phasic event type and click Edit

  1. Go to single click locations
  2. Toggle the Bruxism option
    1. Can be either on or off, just needs to be changed
  3. Click ok
  4. Click ok on settings page

This change puts the Bruxism-Phasic event type in the correct signal group and permanently solves the issue. If multiple computers are sharing the same default settings and all are having these issues, it is necessary to make these changes in Admin mode to apply to all users. If made in local Noxturnal without going to admin mode the changes only apply to the user who is logged in.


 

*Please note that not all features or all products are available in all markets. Our products are medical devices and subject to registration/approval in each market area. For more information on product availability please contact support@noxmedical.com

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